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Δ Product Description 

Fxcommander_Editor is a effect programming software for FXcommander. It can realize the 

program for DMX device and pyro, achieve sync with music. Graph and table mode switchable 

makes it more user friendly in programming. Files can be downloaded with USB disc or USB 

cable. Besides programming, project list table output, device list and statistics etc functions will 

sure minimize operator’s workload.  

NOTE: The FXcommander_Editor software can only be opened when SHOWVEN’s USB disk is 

inserted on computer. It can be removed after entering the editing interface. The USB disk can 

be find in the FXcommander package, please keep it well.  

Δ Project Introduction 

A complete project should include four folders (download, report, wave, xml) and .pro project 

file as shown below. A project corresponds to a continuous show.  

The download folder contains three download files: csv, dot and wave. These three files can 
be downloaded to FXcommander from the Fxcommander_Editor software through a USB cable, 
or copied to FXcommander through a USB disk.

Report folder contains two excel files:  and .  contains 

two sheets: DMX sheet and pyro sheet. Fire_build file shows the device names, quantities, 

address etc information, which are convenient for operator to organize and prepare for the 

show. 

Fire_build.xlsx - DMX sheet 

Fire_build.xlsx - Pyro sheet 

 lists all the cues and their parameter settings in the chronological order of the 

cues created in the project. 



Fire_table.xlsx 

The xml folder is used to store library files. The library files are divided into device library 
(.xml format) and fireworks library (.xlsx format); the device library with the prefix 
dev_SHOWVEN will be recognized as SHOWVEN device library (cannot be edited by 
Fxcommander_Editor software). ), the device library prefixed with dev_USER will be recognized 
as a user library (which can be edited by the Fxcommander_Editor software). Fireworks library 
prefix is pyro_SHOWVEN to be recognized by Fxcommander_Editor software. The format of all 
libraries is strictly defined, please refer to the example and name it accordingly. 

Xml folder 

Δ Main Interface 

The software main interface can be divided into 5 region as above picture shows. 



 

 

1. Control area  2. Lib file display area 3. WAVE waveform area 

4. Cue edit area  5. Device list area  6. Menu 

 

Functions of control area: 

1) Add wave music file, download wave music files to FXcommander 

2) Create dot file and CSV file, download dot files and CSV files to FXcommander 

3) Play, pause, stop music 

4) Volume adjustment 

5) Adding Cue files in the Cue editing area 

6) Important time parameters display, including 

Cue: Current music playing length  

Len: total length of music 

Nex: The time to the next Cue file during music playback 

Pos: The current mouse position on the music timeline 

7) Adjust the size of music graphics (adjusted by setting the value of Audio Magnification) 

8) Adjust the offset between the dot file and the wave music file (adjust the overall early 

trigger time of the dot file by modifying the Audio Start Time); 

9) The bottom part shows the current project version date, click File -> Create Download File 

or download the project file to save the update date 

 

Lib file display area contains device and effects, including pyro library and device library. The 

device library is divided into SHOWVEN lib (cannot be modified) and user lib (can add, delete, 

and modify equipment). Select any library file area, input characters to jump to the device with 

the same initial letter, or use  and  to find and select the device. Double-click to display and 

modify library devices (except SHOWVEN Lib). In addition, deleting and modifying the device in 

library file will not affect the field device. 

The user lib operation menu is shown in the following table: 

Primary menu Secondary menu 

Open File  

 

Device 

Create Device 

Change Device (appear only when selected device) 

Delete Device (appear only when selected device) 

 

Effect 

Create Effect 

Change Effect (appear only when selected effect) 

Delete Effect (appear only when selected effect) 

Save User Xml  

Close User Lib  

 

WAVE waveform area displays the audio curve of the currently added music. Select the audio 

curve and slide the wheel to zoom in and out of the audio curve. Move the mouse to the 

WAVE waveform area, and double-click to drag anywhere in the music playback. 

 

CUE edit area can edit Cue files, including graph and table mode. In table mode, Cue files are 

arranged in the order of adding time from top to bottom; the Cue file to be triggered during 

music playback is white, and the Cue being triggered is Red, Cue before the current music 

playing time is gray. Table and graph modes can be switched in Setting -> View -> Graph /Table. 

 

Cues are arranged in chronological order by default. Click different menus to sort Cues in 

different types (for example, click Model, Cues will be arranged in the order of , , , 

) 



Device list area includes special effects device and pyro device. During music playback, if 

device is being used in the Cue file, the corresponding device in device list area will turn red. If 

the current project uses both special effects device and pyro device, and the set mode is 

automatic, the automatic switching of pyro device and special effects device can be realized 

during the triggering process. Automatic and manual mode can be switched in Setting -> 

Device Window -> Auto/Manual. 

Device in list area can be deleted by select the device - click the shortcut key Delete.  

Menu 

Primary menu Secondary menu Tertiary menu 

Project 

New Project 

Open Project 

Add Project 

Save Project 

Save As Project 

Save As Excel(.xlsx) 

Save As Build 

DMX 
Open Showven Lib 

Open User Lib 

Pyro Open Pyro Lib 

File 

Create Download File 

Download Music 

Download Dot 

Undo 

Redo 

Setting 

Language 
English 

View 
Graph 

Table 

Device Window Auto 



Manual 

MIDI 

Write Midi 

Read Midi 

Smpte 

Disconnect 

Help About 

Project -> New Project: Create a new project; after clicking it, a folder selection window will pop up. A 

new project was created after selecting the folder, enter the name of the new project. 

Project-> Open Project: Open project 

Project-> Add Project: Add other project to current project 

Project-> Save Project: Save current project 

Project-> Save As Project: Save current project as 

Project->Save As Excel(.xlsx): Generate fire_table.xlsx file 

Project->Save As Build: Generate fire_build.xlsx file 

DMX-> Open Showven Lib: Open SHOWVEN Lib 

DMX-> Open User Lib: Open User Lib 

Pyro->Open Pyro Lib: Open Pyro Lib 

File->Create Download File: Create download files, including three files: .dot, .csv, and .wave 

File->Download Music: Download music files, needs to connect with FXcommander 

File->Download Dot Download Dot file, needs to connect with FXcommander 

File->Undo: Undo function to Cue create, copy, move, delete, modify etc operations 

File->Redo: Redo function to Cue create, copy, move, delete, modify etc operations

Setting-> Language->English/Chinese: Language switch 

Setting->View->Graph/Table: Switch the view of Cue edit area; Graph or Table view 

Setting-> Device Window ->Auto/Manual: Auto / Manual setting in Device list region when project is 

running.  

Help->About: Check current FXcommander_Editor software version 

Δ Software Operation 

1. Insert the USB disc to computer.

The FXcommander_Editor software can only be opened when SHOWVEN’s USB disk is

inserted on computer. It can be removed after entering the editing interface. 

The USB disk can be find in the FXcommander package, please keep it well.

2. Create a new project

Double-click the software icon enter software.



Select the folder to save the project, and click Select Folder (the selected folder should includes 

at least two folders named as “wave” and “xml”, where wave contains music files, and xml 

contains lib files). 

Input Project name, click OK to enter the main interface. 



 

 

3. Add music files and devices 

Click open music to select the music you want to add and click Open. After opening, the 

software will automatically save the music files in the wave folder. 

 

Select Showven_Lib, right-click the blank area at the bottom left, select Open File, select the 

library file you want to open, and click Open. Open the User Lib and Pyro Lib in the same way. 

After opening, the library file is automatically saved in the xml folder.  

Fxcommander_Editor can open multiple library files, if the same library file is opened it will be 

displayed repeatedly. 



Right-click the device you want to add and click Add To Device, set the starting address and the 

number of devices, and click Ok. 

4. Edit Cue file

Method A:

Right-click the selected position in the Cue editing area, and click Create to enter the Cue

editing interface.

Select DMX, hold Ctrl and click the device to select devices, or hold the left mouse button and 

drag to select devices. Setting the parameters, click OK. 

Main parameters include Timecode, Duration(s), Tri Delay(s), Prefire(s) (the prefire time set 

cannot exceed the total duration of the Cue file), Times, Cycle, Model and Effect (the effect 

modes include Left to right, right to left, Sync (the trigger time setting is meaningless in this 

mode), sides to middle, middle to sides. 



 

 

Right-click the selected position in the Cue editing area, and click Create to enter the Cue 

editing interface.  

Select pyro, and select the Pyro Lib you want to add in the Pyro column, such as Cakebox red 

bloom (the Pyro Lib is edited in advance, it can be modified at the bottom left, or can edit 

parameters such as start time, duration, Trigger delay, prefire, mode etc in the Cue editing 

interface, but will not be saved);  

Then select the device address, row (0 to F) represents the ignition head address on each slave, 

and the column (00 to FF) represents the slave address.  

Below picture shows selected No. 1 to No. 8 ignition heads of slave No. 00. Click OK to save the 

setting. 



Method B:  

Click  to turn red to enter edit mode, click ▷ to play music. 

Hit the space bar according to the music rhythm during music playback to add empty cue files. 

After adding the empty Cue, click  Reset. 



Right-click the empty Cue, and then click Change to enter the Cue editing interface. Select 

DMX, hold Ctrl and click the device to select devices, or hold the left mouse button and drag to 

select devices. Setting the parameters, click OK. 

Main parameters include Timecode, Duration(s), Tri Delay(s), Prefire(s) (the prefire time set 

cannot exceed the total duration of the Cue file), Times, Cycle, Model and Effect (the effect 

modes include Left to right, right to left, Sync (the trigger time setting is meaningless in this 

mode), sides to middle, middle to sides. 

Edit multi Cue simultaneously. 

Press and hold Ctrl, click to select the Cue(s) need to edit; right click to select Multi Change. 



Select device, setting the parameters and click OK. 

Editing multiple Cues at the same time will modify all selected DMX_Cues, pyro_Cues or empty 

Cues to the same assigned data. Modifying an empty Cue into dmx or pyro has some required 

fields, such as the selected device, selected effect, duration etc.; if not assign data to those 

required items, the modification of an empty Cue will not take effect. 

Edit Pyro Cue. 

Right-click the empty Cue, click Modify to enter the Cue editing interface, Select pyro by 

choose the Name of the pyro. Due to there are large number of different types of pyros, 

operator can use the Filter function of the fields such as Supplier, Fanshape, Class, Color etc. 

The Pyro Lib is edited in advance, it can be modified at the bottom left, or can edit parameters 

such as start time, duration, Trigger delay, prefire, mode etc in the Cue editing interface, those 

changes only effective to present CUE, won’t change the setting in Pyro Lib);  



 

 

Then select the device address, row (0 to F) represents the ignition head address on each slave, 

and the column (00 to FF) represents the slave address. below picture shows selected No. 1 to 

No. 8 ignition heads of slave No. 00. Click OK to save the setting. 

After setting the parameters, play music to check the effect of the setting. 

Click Project->Save Project to save the project, and click File->Create Download File to create 

download files. 

 



 

 

Δ Create User Lib 

1. Create device in User Lib 
Select User_Lib, right-click the lower area and select Device->Create Device, and the window 

shown below will pop up. 

 
2. Add device 

Input the device parameters and click OK to save (* is required).  



 

 

3. Input effect for the device 

Right-click the device name we just added, select Effect -> Create Effect. 

 

Setting the effect parameters and click OK to save (* is required).  



 

 

4. Save the Lib file 

Move the cursor to the Lib File display area, right-click, and click Save User Xml to save the 

parameters. 

Δ Create Pyro Effect 

Select Pyro_Lib, right-click the blank space of Lib file display area, click Create.  



 

 

Input parameters and Click OK to save the setting. 

Move the cursor to the Lib File display area, right-click, and click Save Pyro Csv to save the 

parameters. 



 

 

Δ Merge Project Files 

Merge two project files as show below.  

Click Project -> Add Project 

 

Select the project you want to merge and press Enter 



 

 

Set the time offset of the first Cue of added project, click OK. 

 

Merged projects are show as below. 

Notes for merging projects: 

DMX addresses of the merge projects cannot be occupied by different devices. Please check 

DMX addresses of device after merge, ensure that the DMX channel values do not affect each 

other. 

 



 

 

Δ Shortcut key operation 

Shortcut Key Range Function 

Enter Lib File Add the device in Lib File to Scene device 

Delete ALL Delete selected items 

/  Lib File Up / down 

/  Cue Cue up  / down 

 /  Cue Cue moves backward / forward 10ms 

Shift +  /  Cue Cue moves backward / forward 1s 

Ctrl +  /  Cue Cue moves backward / forward 1min 

Alt +  /  Cue Cue moves backward / forward 1h 

Ctrl + C Cue Copy selected Cue 

Ctrl + V Cue 
Paste the copied Cue at current mouse position  

(can be pasted across projects) 

Ctrl +shift +V Cue 
Paste the copied Cue at previous position  

(can be pasted across projects) 

Ctrl + a Cue Select all Cue 

Space Cue When the red dot is enabled, click Space creates an empty Cue 

Ctrl Cue Hold Ctrl to select multi Cue 

Shift Cue Move the Cue by hold the left mouse button and move the mouse 

when hold Shift 
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